Skip navigation

By trade, I work with computers. I write programs that run on computers and make sure the computers are working properly. It’s a pretty geeky thing, but it’s a pretty straightforward thing for me to do. Most of the time, I’m pretty sure what I want the ultimate goal to be. Sometimes I get lost if the ultimate goal is too amorphous or undefined, but if I’m able to chop the goal into easy to digest bits that have a well defined outcome the process tends to be straightforward. Work on the small bit, while keeping in mind how it fits into the big picture. One thing I do get hung up on is the programmer’s equivalent of writer’s block. I identify the small chunk that needs to be done: a function that will create a directory on the local box as well as create the same directory on remote boxes. Now, what do I name this function? remote_mkdir is kinda long. remkdir is kinda cryptic. rmkdir, ironically enough, is used by another piece of code already (thought that would be the easiest mnemonic for me to remember based on how my brain works). dup_mkdir? 2box_mkdir? rem_md? None of them really make sense to me. And so, instead of implementing the actual code (which inevitably seems to be a straightforward process with a bit of trial and error) I fret over what to actually call things. *sigh*